解决ImportError: cannot import name HTTPSHandler

/usr/local/python3.5/bin/pip3.5 install requests 的时候遇到了cannot import name HTTPSHandler
原因在于openssl,openssl-devel两个文件包未正确安装。用下来的命令来安装

yum install openssl -y
yum install openssl-devel

apt-get安装:

sudo apt-get install openssl 
sudo apt-get install libssl-dev

安装完成后,重新安装python:

cd python3.5
./configure --prefix=/usr/local/python3.5/
make install
Last modification:February 18th, 2019 at 12:24 pm
If you think my article is useful to you, please feel free to appreciate

2 comments

  1. jalena

    你代码哪里抄袭的,,yum openssl-devel这玩意儿能正确执行?

    1. Feng’ Blog
      @jalena

      install写掉了行不行

Leave a Comment