Centos使用rpm时遇到error:Failed dependencies解法方法

环境:Centos 7.4 + gitlab-ce-10.0.0-ce.0.el7.x86_64.rpm

遇到的问题

  1. error: Failed dependencies:
  2. ​ gitlab-ee conflicts with gitlab-ce-10.0.0-ce.0.el7.x86_64
  3. ​ gitlab-ee is obsoleted by gitlab-ce-10.0.0-ce.0.el7.x86_64
  4. ​ gitlab-ce conflicts with (installed) gitlab-ee-11.2.3-ee.0.el7.x86_64
  5. ​ gitlab-ce is obsoleted by (installed) gitlab-ee-11.2.3-ee.0.el7.x86_64

解决办法,在命令后面增加两个参数:--nodeps --force

  1. # rpm -ivh gitlab-ce-10.0.0-ce.0.el7.x86_64.rpm --nodeps --force

解释:

安装时不再分析包之间的依赖关系而直接安装,就不会再提示error: Failed dependencies:这样的错误
rrrrr.png

Last modification:January 9th, 2019 at 01:27 pm
If you think my article is useful to you, please feel free to appreciate

Leave a Comment