deepin15.9系统默认有python2.7和python3.6

一、下载python3.5.4安装包

cd ~
wget https://www.python.org/ftp/python/3.5.4/Python-3.5.4.tar.xz

二、安装一些依赖包

sudo apt-get install openssl
sudo apt-get install libssl-dev

三、解压

xz -d Python-3.5.4.tar.xz
tar xvf Python-3.5.4.tar

四、准备安装

cd Python-3.5.4/
./configure --prefix=/usr/local/python3.5  # 设置安装目录

错误解决:

/usr/bin/install: 无法创建目录"/usr/local/python3.5": 权限不够

解决:

sudo mkdir /usr/local/python3.5

sudo mkdir /usr/local/python3.5/lib

五、软连接

sudo ln -s /usr/local/python3.5/bin/python3 /usr/bin/python3.5

六、查看结果

python3.5 -V
# 显示结果为: Python 3.5.4

安装python3.5.4成功,同时。系统中的python2和python3.6也存在

七、安装pip3.5

sudo ln -s /usr/local/python3.5/bin/pip3.5 /usr/bin/pip3.5

测试:

pip3.5 install dicttoxml
最后修改:2020 年 12 月 31 日 03 : 36 PM
如果觉得我的文章对你有用,请随意赞赏